WCF http error 403.4 – Not found

I went through some of the Microsoft BizTalk Server 2006 R2 WCF Adapter walkthroughs. I struggled somewhat with the Consuming WCF Services with the WCF-BasicHttp Adapter one. When I tried to browse the service (http://localhost/BasicHttpWcfServiceConsuming/OrderProcess.svc) I got the following error page:

HTTP Error 404.3 – Not Found

The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

My OS is Windows Vista, and I had installed Microsoft.NET Framework 3.0 (in addition to 1.1 and 2.0).

My solution was to turn on WCF HTTP Activation in Microsoft .NET Framework 3.0. (You get to this setting via Add or Remove Programs, Turn Windows features on or off.) See attached screen shot. (Click on the image for the full size version.)

WCFHTTPActivation

An alternative is to run the following command:

"C:WindowsMicrosoft.NETFrameworkv3.0Windows Communication FoundationServiceModelReg.exe" -i

As a side note, the walkthrough in the update help file (downloaded 20 May 2008) lacks some steps under the heading To deploy the sample BizTalk solution, BizTalkApp. See the online version for the complete steps.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s